I need APN Settings for my Galaxy S3 on Straight Talk (AT&T)

Discussion in 'Straight Talk' started by rhyze, Jul 17, 2013.

  1. rhyze

    rhyze New Member

    Joined:
    Jun 17, 2013
    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    3
    I have a Galaxy S3 on ST with an AT&T SIM but I don't get to send MMS and speed is so slow.

    I think my APN is not correct.

    Someone help please!
  2. james

    james Prepaid Newbie

    Joined:
    Apr 24, 2013
    Messages:
    36
    Likes Received:
    3
    Trophy Points:
    8
    maybe you are throttled?
  3. rhyze

    rhyze New Member

    Joined:
    Jun 17, 2013
    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    3

    I don't think so.. Only been using it for a week.
  4. Jason A

    Jason A Prepaid Expert

    Joined:
    Jan 25, 2013
    Messages:
    648
    Likes Received:
    127
    Trophy Points:
    63
    rhyze, give this a try:


    Name: Straight Talk
    APN: att.mvno
    Proxy: Not set
    Port: Not set
    User name: Not set
    Password: Not set
    Server: Not set
    MMSC: http://mmsc.cingular.com
    MMS Proxy: proxy.mvno.tracfone.com or 66.209.11.33
    MMS Port: 80
    MCC: 310
    MNC: 410
    Authentication type: Not set
    APN type: default,supl,mms,hipri <== NO SPACES between values
    APN Protocol: IPv4
    Enable/Disable APN: (checked/APN enabled)
    Bearer: Unspecified
    • Like Like x 1
    • Winner Winner x 1
  5. rhyze

    rhyze New Member

    Joined:
    Jun 17, 2013
    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    3
    nice, very nice!! got it working now! thank you.
  6. LylaDee

    LylaDee Prepaid Newbie

    Joined:
    Apr 17, 2013
    Messages:
    44
    Likes Received:
    1
    Trophy Points:
    8


    This is working.. I tried it with my friends phone.
  7. Dylan Ortiz

    Dylan Ortiz New Member

    Joined:
    Sep 5, 2013
    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    1
    Hey Jason,
    I tried these setting because I just activated my straight talk sim TODAY and entered these setting into my AT&T Galaxy S3 and i rebooted my phone. But I still dont have any MMS or Internet... HELP ME!!! PLEASE SOMEONE HELP ME OUT
  8. Jason A

    Jason A Prepaid Expert

    Joined:
    Jan 25, 2013
    Messages:
    648
    Likes Received:
    127
    Trophy Points:
    63

    Dylan Ortiz , give this a try

    Name:Straight Talk
    Apn:tfdata
    skip down to Mmsc
    Mmsc:http://mms-tf.net
    Mms proxy:mms3.tracfone.com
    Mms port:80

    Seems to work with other ST users with Galaxy S3
  9. Jason A

    Jason A Prepaid Expert

    Joined:
    Jan 25, 2013
    Messages:
    648
    Likes Received:
    127
    Trophy Points:
    63
    You can try this also:

    Name=Straight Talk
    APN=att.mvno
    Proxy=proxy.mvno.tracfone.com
    Port=80
    MMSC=http://mmsc.cingular.com
    MMS proxy=mms2.tracfone.com

    Let me know if any of it worked.
  10. Bomberman

    Bomberman Prepaid Newbie

    Joined:
    Apr 17, 2013
    Messages:
    41
    Likes Received:
    2
    Trophy Points:
    8
    You can give ST a call. I had same problem before, I called ST and got the correct APN in less than 10 mins.
  11. Dylan Ortiz

    Dylan Ortiz New Member

    Joined:
    Sep 5, 2013
    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    1
    Yea i tried your settings and NOTHING! Then I contacted ST and they gave me the same stuff but of course they took forever and NOTHING!!

    So then finally last night, i was messing around with it and mixed it up a little. and IT WORKS NOW!!! Here is what I have.

    Name: Straight Talk
    APN: tfdata
    Proxy: proxy.mvno.tracfone.com
    Port:80
    User name: Not set
    Password: Not set
    Server: Not set
    MMSC: http://mmsc.cingular.com
    MMS proxy: 66.209.11.33
    MMS port: 80
    MCC: 310
    MNC: 410
    Authentication type: Not set
    APN type: Not set
    APN protocol: IPv4 (cannot change)
    Enable/disable APN: APN enabled with check (cannot change)
    Bearer: Unspecified

    I am so happy. I have 4G and everything!!!!
    • Like Like x 2
  12. Jason A

    Jason A Prepaid Expert

    Joined:
    Jan 25, 2013
    Messages:
    648
    Likes Received:
    127
    Trophy Points:
    63
    Dylan Ortiz, awesome man! Glad you figured it out your self.

    Yea, most of the time CS can't help. You'll have to figure it out or ask around.

    Btw, I fixed the link. ;)
  13. Reez89

    Reez89 Prepaid Newbie

    Joined:
    Apr 17, 2013
    Messages:
    48
    Likes Received:
    2
    Trophy Points:
    8

    I tried this with my friends phone and it works 100%!
  14. travis boyce

    travis boyce New Member

    Joined:
    Sep 9, 2013
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    APN Name: Straight Talk
    APN: tfdata
    Port: 80
    MMSC: http://mms-tf.net
    MMS Proxy: mms3.tracfone.com
    MMS Port: 80
    Delete the current APN from your phone.
    Reboot your phone.
  15. jessica8jessica

    jessica8jessica New Member

    Joined:
    Monday
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I am another having the E speed (< 1 Mbps) and would love 3 or 4G again! (all text/pic everything works no problem)
    I've tried what feels like all combos possible from many different forums lol. I did chat w straight talk and they gave me what is in the post above this. This did not help.
    I do have wifi turned off.
    I've rebooted my phone after changing the APN.
    The only thing i haven't done is delete all the old APNs...i have a bunch of them (i named them different users names and put in their settings to keep track of them :) ) Is this a 'must do' step?

    I do know my phone is 4G capable as i was using it on Verizon with 4G before i switched it to straight talk.
    Would reseating my phone back to default be a must? I would think not...and i do realize it could be a last ditch effort, but would rather not if i don't have to of course :)

    Under Settings >> More Settings >> Mobile networks
    When i switched over to ST my 'Network Mode' was 'Global' (i am only paying the $45 for the non-international plan).
    I did change this to GSM/UMTS
    Then under 'Network operators' i chose AT&T (no T-Mobile service here)(i also tried 'select automatically' but there was no difference).

    --should i leave 'Network Mode' as 'Global'
    --should i choose 'Select automatically' vs choosing 'AT&T' under 'Network operators'

    Thanks for any and all help!!

Share This Page